Forum

Proleme nach Update...
 

[Gelöst] Proleme nach Update -> Ubuntu 18.04 mit Chromis 0.56.2  

   RSS

0

Hallo zusammen,

 

habe eben von Ubuntu 16.04LTS ein Update auf 18.04LTS 64bit gemacht.

So weit so gut, wenn ich jetzt Chromis POS starte bekomme ich den Hinweis Datenbank nicht gefunden, wenn ich aber in der Chromis Konfiguration einen Datenbank Verbindungstest mache, zeigt es mir You're Connected an, also alles in Ordnung, hat jemand eine Idee was das sein könnte ?

Das wäre übrigens nach dem Startbefehl von Chromis die Ausgabe auf der Konsole:

Nov 01, 2018 3:50:09 PM uk.chromis.pos.forms.AppConfig <init>
INFORMATION: Reading configuration file: /home/kasse1/chromispos.properties
java.io.FileNotFoundException: Source '/home/kasse1/Icon sets/blue/images.jar' does not exist
Nov 01, 2018 3:50:11 PM uk.chromis.pos.forms.AppConfig <init>
INFORMATION: Reading configuration file: /home/kasse1/chromispos.properties
Nov 01, 2018 3:50:12 PM uk.chromis.data.loader.StaticSentence openExec
INFORMATION: Executing static SQL: SET storage_engine=INNODB
Nov 01, 2018 3:50:12 PM uk.chromis.data.loader.PreparedSentence openExec
INFORMATION: Executing prepared SQL: SELECT VERSION FROM APPLICATIONS WHERE ID = ?

 

Viele Grüße

Stefan

10 Answers
1

Hab den Fehler gefunden, habe mal die altew my.cnf mit der neuen verglichen, stellte fest dass

lower_case_table_names = 1

nicht drinn steht, habe das hineingeschrieben, und siehe da, es funktionierte

 

vielen vielen Dank für die hilfe und deine geduld :-)

 

lg

Stefan

0

Servus @odin1

Das Du hier im QRK Forum bist weißt Du? 😉 

Gibt es überhaupt ein Chromis Forum?

Ich kenne und verwende kein Chromis, aber gibt es für Chromis ein Logfile?
Auch das MySQL/MariaDB Log wär noch ein Punkt wo Du nachsehen kannst.

Du kannst es auch anhängen, vielleicht seh ich ja was. Bei MySQL und MariaDB hat sich da einiges geändert. Ich musste auch bei QRK dafür änderungen bei manchen SQL Abfragen machen.

Wahrscheinlich liegt es am SQL Mode

default MySQL 5.7 ONLY_FULL_GROUP_BY STRICT_TRANS_TABLES NO_ENGINE_SUBSTITUTION

default mySQL 5.6 NO_ENGINE_SUBSTITUTION

This post was modified vor 6 Monaten 2 times by chris

LG
Chris
_________________

mir schon klar, dass das hier nicht das chromis Forum ist, dachte halt nur weil hier auch viele mit chromis arbeiten und ich ja chromis und qrk nutze

das ist mal das MySQL Log

 
bei chromis habe ich nichts gefunden.
0

Der link funktioniert leider nicht.

Schick mir mal was ein

cat /etc/my.cnf
ausgibt.

LG
Chris
_________________

cat: /etc/my.cnf: Datei oder Verzeichnis nicht gefunden
0

Ok

log dich mal auf Deinen SQL Server ein und schick mir die Ausgabe von

  1. mysql> SELECT @@GLOBAL.sql_mode;
  2. mysql> SELECT @@SESSION.sql_mode;

 

LG
Chris
_________________

mysql> SELECT @@GLOBAL.sql_mode;
+-------------------------------------------------------------------------------------------------------------------------------------------+
| @@GLOBAL.sql_mode |
+-------------------------------------------------------------------------------------------------------------------------------------------+
| ONLY_FULL_GROUP_BY,STRICT_TRANS_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION |
+-------------------------------------------------------------------------------------------------------------------------------------------+
1 row in set (0.00 sec)

 

mysql> SELECT @@SESSION.sql_mode;
+-------------------------------------------------------------------------------------------------------------------------------------------+
| @@SESSION.sql_mode |
+-------------------------------------------------------------------------------------------------------------------------------------------+
| ONLY_FULL_GROUP_BY,STRICT_TRANS_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION |
+-------------------------------------------------------------------------------------------------------------------------------------------+
1 row in set (0.00 sec)

 

0

Ich geh mal davon aus das es an den neuen Defaults liegt. Um das zu testen versuch mal

mysql> SET sql_mode = '';

und starte Chromis. Sollte es funktionieren muß ich erst schauen wo man das permanent macht. Wenn Du den SQL Server neu startest ist alles wieder beim alten.

Geb mir mal Bescheid obs das war.

LG
Chris
_________________

das wars nicht, leider den selben Fehler

Den Server hast aber in der zwischenzeit eh nicht neu gestartet.
Wenn es  nicht daran liegt werd ich Dir nicht mehr weiterhelfen können. Liegt dann wohl an Chromis selbst. Ist das Deine Live WS?

0

Versuch mal ein Chromis Update.

+Fixed icon set install that stopped linux running

Ist evtl. der File not Found Fehler den man auf Deiner Konsole sieht

LG
Chris
_________________

0

Habe ich gerade mal versucht, leider ohne Erfolg. Ich kapiere das nicht. Wenn ich das Config File aufrufe geht die Datenbankverbindung, wenn ich das Programm starte verbindet die Datenbank nicht.

Die Gastroerweiterung für QRK ist ja wohl leider wieder eingeschlafen, würde ja liebend gerne auf Chromis verzichten, aber ich brauche eben eine Tischverwaltung

0

vielleicht liegt es ja an der Java Version. Java ist immer etwas problematisch.

Chromis brauch glaub ich Version 8. Vielleicht ist ja die Version 10 installiert.

sudo apt install openjdk-8-jre

 

LG
Chris
_________________

0

@odin1 Den Status der QRK Web Erweiterungkenn ich jetzt auch nicht genau. Da kann  christian.a (@christian-a) sicher mehr dazu sagen.

LG
Chris
_________________

0

Die Gastro Geschichte funktioniert soweit. Nur mit chromis als Frontend dazwischen hab ich noch Probleme. 

Weitere Infos gern per PM!

 

LG Christian

lokale, regionale Bioprodukte?
www.stoecklWEINgarten.at

Ich würde mich ja gerne von Chromis verabschieden und nur mehr QRK nutzen, von daher :-) Was halt wichtig wäre, dass die Artikel und Warengruppen aus Chromis übernommen werden, sonst müsste man ja alles neu anlegen

 

lg

Stefan

Share:

Bitte beachte auch unsere Knowledgebase und das Handbuch!