Forum

Monatsabschluss zu früh erstellt  

Seite 1 / 2
  RSS
Tom
 Tom
(@thomask)
Eminent Member

Hallo

 

wir haben das Problem, dass am 14.9 scheinbar automatisch ein Monatsabschluss für September erstellt wurde. Manuell kann man das ja nicht machen, oder?

nun ist es so, dass alle Belege die über die Serverfunktion rein kommen nicht funktionieren sondern ne Fehlermeldung bringen (Monatsabschluss bereits erfolgt). Die Files im Importverzeichnis werden automatisch auf .false umbenannt.

weiters kann ich den Haken bei Servermodus nicht mehr manuell setzen. Über den Schalter -servermode in der Verknüpfung wird es zwar automatisch gesetzt, kann aber auch nicht deaktiviert werden.

Bitte um Hilfe, da wir keine Belege mehr drucken können.

 

vielen Dank

lg

Tom 

Dieses Thema wurde geändert 4 Wochen zuvor von Tom
Zitat
Veröffentlicht : 17. September 2019 11:14
Tom
 Tom
(@thomask)
Eminent Member

kurzes Update:

bei einer anderen Filiale mit der selben Version (1.12.1) hab ich das Problem nicht. da ist das Feld "Servermode" nicht ausgegraut und ich kann den Haken ganz normal rausnehmen.

 

lg

Tom

AntwortZitat
Veröffentlicht : 17. September 2019 11:44
chris
(@chris)
Prominent Member Admin

@thomask

Hallo

Der Abschluss kann natürlich auch manuell gemacht werden. So wie es aussieht hat aber irgendwer am 14.9 die Kasse geschlossen. Sprich außer Betrieb gesetzt. Das geht nur manuell in den Einstellungen.
Einfach ein backup vorm Abschluss wieder herstellen sollte das beheben. Wenn QRK SQLite verwendet findet man die DB als zip im backup Ordner. Bei MySQL wird von der Kasse aus kein backup erstellt.

LG
Chris
_________________

AntwortZitat
Veröffentlicht : 17. September 2019 12:06
Tom
 Tom
(@thomask)
Eminent Member

hi

kannst Du mir bitte sagen wo das in den Einstellungen zu machen ist? wenn jemand (ein Mitarbeiter in der Filiale) die Kasse ausser Betrieb genommen hat, müsste man sie ja wieder komplett neu in Betrieb nehmen, odeR?

wegen Backup: was passiert mit den Buchungen die seit dem Backup gemacht wurden? die Importfiles bleiben zwar bestehen und ich kann sie umbenennen... aber das DEP stimmt dann ja nicht, oder?

lg

Tom

Diese r Beitrag wurde geändert 4 Wochen zuvor von Tom
AntwortZitat
Veröffentlicht : 17. September 2019 12:16
chris
(@chris)
Prominent Member Admin

@thomask

Einstellungen -> Signaturerstellungseinheit
Wenn die Kassa in betrieb ist steht neben Test, Kasse außer Betrieb nehmen.

Nachdem ja nach den Abschluss keine Bons mehr gedruckt wurden soll das kein Problem sein. Das DEP wird ja mit gesichert.

 

LG
Chris
_________________

AntwortZitat
Veröffentlicht : 17. September 2019 12:51
Tom
 Tom
(@thomask)
Eminent Member

@chris

ich finde diese einstellung gar nicht. In der Menüleiste steht jedoch 

Datei         Hilfe            "NEUE KASSE ERSTELLEN"

 

das heisst dann wohl es hat sie wirklich jemand ausser Betrieb genommen, oder?

AntwortZitat
Veröffentlicht : 17. September 2019 13:57
Tom
 Tom
(@thomask)
Eminent Member

hi chris

hab grad nachgesehen. ich hab nur ein backup von der datenbank (2019-QRK.db , 2019-QRK.db-shm , 2019-QRK.db-wal) sowie das extern gesichte DEP. Aber leider kein Backup von gesamten QRK Verzeichnis. So wie es aussieht muss ich dann die Kasse beim Finanzamt neu erstellen, oder?

 

lg

Tom

AntwortZitat
Veröffentlicht : 17. September 2019 14:24
chris
(@chris)
Prominent Member Admin

@thomask

Du brauchst ja auch nur die DB

LG
Chris
_________________

AntwortZitat
Veröffentlicht : 17. September 2019 17:08
Tom
 Tom
(@thomask)
Eminent Member

@chris

hab die datenbank wiederhergestellt. bekomme aber einen dep fehler...siehe anhang

das komische dabei ist, dass er belege anmeckert, die es noch gar nicht geben kann... zb 21770 (siehe anhang). wir sind bei den belegen erst bei 215xx.

es werden auch alte belege angemeckert ... zb9846... die eigentlich auch nicht fehlen können. angefangen hat das alles am Samstag. dann hat der Mitarbeiter dort leider auf Kassa ausser Betrieb nehmen geklickt bei der Fehlermeldung.

wenn das jetzt zuviel aufwand ist das zu reparieren, werde ich am 30.9 die Kasse ausser Betrieb nehmen und am 1.10 neu machen. 

 

 

AntwortZitat
Veröffentlicht : 17. September 2019 18:02
chris
(@chris)
Prominent Member Admin

@thomask

Hallo

Eigenartig. Vielleicht eine falsche Backup Datei erwischt? Alle Dateien aus der zip entpackt?
Wurde die Kasse schon mal neu begonnen? Wann wurden die Updates gemacht?

Bitte mal die Logdatei senden. (an info@ckvsoft.at)

LG
Chris
_________________

AntwortZitat
Veröffentlicht : 17. September 2019 20:26
Tom
 Tom
(@thomask)
Eminent Member

@chris

hi

ich hab denk ich schon die richtige backup datei erwischt. wo finde ich die logs?

lg

Tom

AntwortZitat
Veröffentlicht : 5. Oktober 2019 10:14
Tom
 Tom
(@thomask)
Eminent Member

Hab das log file gefunden. schicke ich dir gleich zu.

lg

Tom

AntwortZitat
Veröffentlicht : 5. Oktober 2019 10:29
chris
(@chris)
Prominent Member Admin

@thomask

Hab ich bekommen, danke

Verwendest Du unterschiedliche QRK Versionen? Ist die Kasse mehr als einmal in unterschiedlichen Verzeichnissen installiert?
Im Logfile habe ich gesehen das von Version 1.10.1 auf die Version 1.12 und gleich danach auf Version 1.12.1 ein Update gemacht wurde. Und dann etwas später allerdings wieder die Version 1.10.1 verwendet wird. Dann wieder die Version 1.12.1.

Da sehe ich noch das es überdurchschnittlich viele Smartcard Fehler gibt. Welcher Reader wird verwendet?
Die mitgelieferte DB ist aus 2018. (Absicht??)

Nicht ersichtlich sind natürlich diverse Debugausgaben, dazu müsste QRK mit dem Parameter -d gestartet werden.

LG
Chris
_________________

AntwortZitat
Veröffentlicht : 5. Oktober 2019 15:04
Tom
 Tom
(@thomask)
Eminent Member

@chris

Hi. nein, es ist nur eine Version installiert. Ich mache nicht immer gleich die Updates. beim letzten Update (nach automatischer Meldung) auf die Version 1.12 kam sofort beim nächsten Öffnen von QRK wieder ne Update Aufforderung. 

Die Version 1.10.1 danach wird wohl vom Restore kommen.

Cardreader ist ein Gemalto IDBridge CT40 . den haben wir von A-Trust gekauft und dieser läuft auch bei allen anderen Kassen.

Die eine DB aus 2018 hab ich versehentlich angehängt. Ich war auf der Suche nach den Logfiles in Appdata\Roaming usw... da war diese DB drin.

hab ich die aktuelle nicht auch angehängt? 

AntwortZitat
Veröffentlicht : 9. Oktober 2019 18:04
chris
(@chris)
Prominent Member Admin

@thomask

Hallo

Nein die Aktuelle DB war nicht dabei. Beim Restore hätte nur die DB und nicht auch die App zurück gespielt werden müssen.
Zu beachten ist das die Rechnungsnummer beim Import nicht gleich die in der Kasse sind. Es gab in älteren Versionen einen Fehler beim Runden. Sprich wenn Du lange eine alte Version im Einsatz hast ist zwar der Fehler die ganze Zeit da jedoch erst beim Update sichtbar. Die alte Version wusste ja auch nichts vom Fehler.

Evtl. Muss die Kasse mit der neuen Version neu in Betrieb genommen werden.

LG
Chris
_________________

AntwortZitat
Veröffentlicht : 9. Oktober 2019 18:27
Seite 1 / 2
Share:

Bitte beachte auch unsere Knowledgebase und das Handbuch!