Forum

Onboard Tastatur nicht mehr angezeigt  

  RSS
Tomas
(@tdvorak)
Active Member

Hallo alle,

Ich verwende die QRK auf einem all-in-one PC mit Touchscreen. Dazu hab ich in Ubuntu 18.04 die virtuelle Onboard Tastatur. Seit dem letzten Update wird die Tastatur nicht mehr automatisch angezeigt, wenn ich den Cursor in einem Input-Field (Artikel Manager, Kunden Zusatztext, Filter Beleg, ...) habe. Bei allen anderen Apps funktioniert es problemlos (Firefox, Terminal, ...). Das Gleiche kann ich auf einem anderen Computer reproduzieren (QRK v 1.10.2.Build-121228).

Hat jemand eine Idee, was das sein könnte? Betriebt iht die Kasse auch mit einer virtuellen Tastatur?

Danke,
Tomas

 

AntwortZitat
Veröffentlicht : 29. Januar 2019 7:52
chris
(@chris)
Honorable Member Admin

Servus
Ich hatte das mal vor einigen Versionen auf einen Touch mit Ubuntu am laufen. Ich muss schauen ob ich noch einen Touch-Monitor habe und werde das mal testen.
Funktioniert das in allen Bereichen nicht mehr oder nur im Kassenmodus? Habe an den Eingabefeldern nichts geändert.

LG
Chris
_________________

AntwortZitat
Veröffentlicht : 29. Januar 2019 16:17
chris
(@chris)
Honorable Member Admin

Hast Du vielleicht in den Einstellungen -> Kassa -> Barcode Lesegerät -> Barcode-Eingabe als Voreinstellung aktiviert? Vielleicht kann es damit zusammen hängen.

LG
Chris
_________________

AntwortZitat
Veröffentlicht : 29. Januar 2019 16:23
Tomas
(@tdvorak)
Active Member

Hi, danke für schnelle Antwort!

Ich muss schauen ob ich noch einen Touch-Monitor habe und werde das mal testen.

Kannst du auch ohne Touch-Monitor testen, sollte genauso funktionieren. Ich hab es auf einem Computer mit Touchscreen und zwei ohne getestet, überall das Gleiche. In Onboard Settings einfach 'auto-show when editing' aktivieren.

Funktioniert das in allen Bereichen nicht mehr oder nur im Kassenmodus?

Keine Text-Felder triggern die Tastatur (Artikel Manager, Settings, Kasse). Also die Onboard Tastatur funktioniert überall als Input-Device, wird aber nicht automatisch angezeigt, wenn das Feld focus kriegt. Vielleicht blockiert etwas die focus Events?

Hast Du vielleicht in den Einstellungen -> Kassa -> Barcode Lesegerät -> Barcode-Eingabe als Voreinstellung aktiviert? Vielleicht kann es damit zusammen hängen.

Hab ich nicht, beides hab ich gerade getestet und es ändert sich nichts. Kann ich die Plugins irgendwie ausschalten?

Es ist vielleicht ein Bug in Ubuntu, Qt oder Onboard. Ist ja nicht urgent, ich brauche die Tastatur nur sehr selten und kann sie manuell anzeigen. Es ist halt nicht mehr so bequem und früher hat es funktioniert.

Danke,
Tomas

AntwortZitat
Veröffentlicht : 29. Januar 2019 19:59
chris
(@chris)
Honorable Member Admin

Ich schau mir das an.

LG
Chris
_________________

AntwortZitat
Veröffentlicht : 29. Januar 2019 21:49
Share:

Bitte beachte auch unsere Knowledgebase und das Handbuch!